Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w00a4c97/ag/SMF2/Sources/Load.php(225) : runtime-created function on line 3
ASPI-Probleme, Computer friert ein, stürzt ab
Hauptseite

Deutsches
Forum
Willkommen Gast. Bitte einloggen oder registrieren.
23. Mai 2017, 07:59:21
Übersicht Hilfe Suche Einloggen Registrieren

+  Audiograbber.de Forum
|-+  Audiograbber
| |-+  Häufige Fragen rund um Audiograbber (Moderatoren: Stefan, start78)
| | |-+  ASPI-Probleme, Computer friert ein, stürzt ab
0 Mitglieder und 1 Gast betrachten dieses Thema. « vorheriges nächstes »
Seiten: [1] Drucken
Autor Thema: ASPI-Probleme, Computer friert ein, stürzt ab  (Gelesen 146824 mal)
Cheinzle
Gast


E-Mail
ASPI-Probleme, Computer friert ein, stürzt ab
« am: 2. September 2003, 15:33:16 »

Bis auf Weiteres raten wir davon ab, unter Windows Vista ASPI-Treiber zu installieren!
Wer es dennoch macht handelt auf eigene Verantwortung. Erfahrungen mit ASPI-Problemen unter Vista können hier mitgeteilt werden.

Symptome

Beim digitalen Auslesen (Grabben) kommt es zu Fehlermeldungen wie "ASPI-Fehler", "ASPI antwortet nicht", oder "Neuer Versuch in 4 Sekunden". Auch sind Symptome wie das Einfrieren des PCs schon beim Starten von Audiograbber oder Bluescreens beim Wechseln der CD dokumentiert.


Was steckt dahinter?

Es gibt wohl keine Frage, die seit der Verbreitung von Windows XP so häufig gestellt wird wie die wegen ASPI-Problemen.
ASPI, oder genauer der ASPI-Layer, wurde ursprünglich nur zur Ansteuerung von SCSI-Laufwerken benötigt. Jedoch wird auch beim Grabben, auch von IDE-Laufwerken, dieser Layer verwendet, um die Audio-Daten einer CD in ein computerlesbares Format zu verwandeln.
Früher waren ASPI-Probleme ein absolutes Fremdwort, da der Layer standardmäßig in den Betriebssystemen Windows 9x und Me integriert waren. Mit der Umstellung auf die NT-Schiene auch im Consumerbereich, insbesondere durch Windows XP, wurde das Problem immanent, denn bei den NT-Betriebssystemen wird kein solcher Layer mitgliefert. Stattdessen gibt es eigene Befehle, die an und für sich das Gleiche bewirken sollten wie ASPI, doch funktionieren diese mehr schlecht als recht. Es empfiehlt sich daher, einen funktionsfähigen ASPI-Layer zu installieren.


Wo ist das Problem?

In manchen Bereichen macht es die EDV-Industrie dem Anwender wirklich schwerer als notwendig. Das Internet ist voll mit den verschiedensten Layern und Tipps, wie diese zum Laufen gebracht werden. Es gibt solche zum installieren, solche zum kopieren, solche zum selber stricken, Nero ASPI, ForceASPI, ASPIme, Adaptec ASPI, ...
Die große Schwierigkeit ist die, daß viele dieser Layer wieder einen großen Aufwand erfordern, um installiert zu werden - und dann kann es auch noch passieren, daß sie fehlerhaft sind oder nur unbefriedigend funktionieren. Adaptec ASPI ab 4.70 ist dafür ein gutes Beispiel, unter Umständen hat man nachher mehr Probleme als vorher.


Gibt's keine einfache Lösung?

Die gibt es. Es gibt einen Layer, der sich in zahllosen Versuchen immer als fehlerfrei und bestens geeignet erwies: "ASPI!" Er läßt sich ganz einfach installieren und behebt zuverlässig alle Probleme.
In sehr seltenen Fällen jedoch setzen sich andere Layer, insbesondere Adaptec 4.71, so hartnäckig im System fest, daß die Installation von ASPI! scheitert. In diesem Fall muß der Spezialist ran: Killaspi. Dieses Programm schickt jeden zuvor installierten Layer zuverlässig in die ewigen Jagdgründe, und der Installation von ASPI! steht nichts mehr im Wege.


Zum Herunterladen...

ASPI! herunterladen

Killaspi herunterladen (nur wenn notwendig)


Installation: Was ist zu beachten?

Nach dem Herunterladen von ASPI! kann die Installation mit einem einfachen Doppelklick gestartet werden. Danach muß man im Prinzip nur immer auf "Next" klicken und den Anweisungen folgen. nach einem Neustart des Computers sollten alle ASPI-Probleme erledigt sein.

Achtung bei Benutzerkonten mit eingeschränkten Rechten (Windows 2000/XP): Der ASPI-Layer muß zunächst mit Administratorrechten installiert werden. Um sich das Leben einfach zu machen, installiert man zusätzlich (als Administrator) die nero BurnRights und verteilt entsprechend die Rechte oder sagt einfach jeder darf auf die Treiber zugreifen.

Sollte der seltene Fall eintreten, daß es immer noch nicht funktioniert, klicken Sie in Audiograbber auf Hilfe/Systeminformationen. Bei ASPI sollte stehen: "ASPI for WIN32  ATAPI". Steht hier ein Vermerk "funktioniert aber nicht richtig", so muß man mit Killaspi nachhelfen. Nach dem Herunterladen genügt ein Doppelklick, danach ein Neustart. Der alte ASPI-Layer ist nun garantiert entfernt. Sodann kann die Installation von ASPI! wiederholt werden. Dieser Fall ist aber sehr selten.

Regelmäßig muß nach der Installation Audiograbber auf die Verwendung von ASPI umgestellt werden. Dies geschieht durch einen einfachen Klick auf den Button Optionen. Dort muß nun auf ASPI umgestellt werden (siehe Screenshot).




Wenn es immer noch nicht funktioniert...

...verzweifeln manche Leute schon. Doch spätestens hier liegt kein Problem mehr mit ASPI selbst vor, sondern das Zusammenspiel mit anderen Systemkomponenten scheitert.

Oft liegt es in diesem Fall am nicht aktivierten DMA-Modus. Standardmäßig wird dieser für den ersten IDE-Kanal aktiviert, der zweite jedoch auf PIO belassen. Warum Windows in seltenen Fällen dieses Phänomen aufweist, ist schwer nachzuvollziehen.
Klicken Sie mit der rechten Maustaste auf "Arbeitsplatz", dann Eigenschaften. Klicken Sie nun auf die Registerkarte "Hardware", dann auf den Button "Geräte-Manager". Wählen Sie hier den Baum "IDE/ATA ATAPI-Controller" aus:



Doppelklicken Sie danach auf die beiden oberen Einträge und wechslen Sie zur Registerkarte "Erweiterte Einstellungen" Stellen Sie hier sowohl für den primären wie den sekundären Kanal sicher, daß überall "DMA, wenn verfügbar" ausgewählt ist. Sollten Sie etwas ändern müssen, ist danach ein Neustart fällig.




Fehlerquelle: Die CD selbst

Wenn es jetzt immer noch nicht funktioniert, kann es nur noch an der CD selbst liegen. Hier ist zumindest die Suche nach der Lösung sehr einfach: Probieren Sie eine andere CD aus. Funktioniert es, untersuchen Sie die urspüngliche CD.

CD zerkratzt:
Eine häufige Ursache: Der Datenbereich der CD ist verkratzt, und das Laufwerk selbst kann damit nicht mehr umgehen. Hier hilft nur, es in einem anderen Laufwerk zu versuchen. Auch oft zu finden: Die Unterschrift des Besitzers, sprich ein schöner, fettiger Fingerabdruck. Der läßt sich mit einem fusselfreien Tuch mit Putzbewegungen von innen nach außen (nie kreisförmig!) gut entfernen.
Bei leichten Kratzern hilft der gute alte Zahnpastatrick: Mit einem winzigen Tropfen Zahnpasta den Kratzer bedecken, leicht mit dem Finger verreiben und überschüssiges Material mit einem weichen Tuch sorgfältig entfernen. Nicht zu fest drücken, aber gleichmäßig von innen nach außen alle Schlieren entfernen. Achten Sie aber unbedingt darauf, daß Sie eine weiße Zahnpasta ohne Scheuermittel verwenden. Was die Zähne weißer macht, sind kleine Schleifkörnchen, die der Oberfläche noch mehr schaden als nutzen. Ohne jetzt Werbung zu machen, fällt mir nur Elmex ein, denn Blend a Med Classic gibt es nicht mehr zu kaufen (Classic Plus hat Schleifmittel!).

CD kopiergeschützt:
Auch der Versuch, eine kopiergeschützte CD zu grabben, kann zu einem ASPI-Fehler führen. Bitte beachten Sie, daß das Umgehen oder Aushebeln eines Kopierschutzes gemäß § 95a UrhG verboten ist. Ich kann daher dazu keine Stellungnahme oder "Tips" abgeben.


Noch immer nicht den Fehler gefunden?

Spätestens jetzt kann es niemandem verübelt werden, wenn er das Handtuch wirft. Aber auch hier gibt es zumindest eine letzte Brücke: Das Team des Audiograbber-Forums nimmt sich dieser Spezialfälle immer an und versucht, den Fehler zu ergründen.
Machen Sie bei der Anfrage möglichst genaue Angaben zu System, was Sie bereits versucht haben, etc. Seien Sie nicht böse, wenn wir erst einmal auf diesen Thread hier wieder verweisen - denn viele Leute lesen nicht alles. Wir können auch keine Lösung aus dem Hut zaubern - sondern können nur durch Fragen das Problem eingrenzen und zuletzt hoffentlich einen Lösungsweg aufzeigen.

Erstellen Sie eine neue Frage im Hauptbereich des Forums

Zusatz:
Nach dem Grabben einer zerkratzten CD grabbt das Laufwerk deutlich langsamer


Dieser Tipp stammt aus dem Forum und ist in voller Länge hier nachzulesen.

Windows hat ein historisches Feature (bzw. heute ggf. Bug), welches den DMA-Modus eines optischen Laufwerkes nach etwa 6-maligem fehlerhaften Zugriff (in Windows) deaktiviert und stattdessen den deutlich langsameren und CPU-belastenderen PIO-Modus für dieses Laufwerk (in Windows) aktiviert.
Dies kann man im Gerätemanager unter den Eigenschaften des IDE-Controllers, an dem das optische LW hängt, überprüfen. Eine Änderung auf DMA an dieser Stelle mit Neustart hat keinen Erfolg!! Das Laufwerk ist (erst einmal) unter Windows auf den langsamen PIO-Modus festgenagelt. Man wird hierüber auch nicht informiert!

Auf dieser Seite sind mehrere Lösungsansätze samt ausführlicher Beschreibung zu finden:
http://winhlp.com/WxDMA_D.htm

Ein kurzer Test mit der "schnellen Methode" über das Visual Basic Programm "resetdma.vbs" verursachte keine Probleme. Grundsätzlich raten wir jedoch zur Vorsicht! Ich bitte um Rückmeldungen im Ausgangs-Thema (positive und negative!), um die Erfolgsquote zu ermitteln.


Wir hoffen sehr, mit dieser Anleitung gedient zu haben und wünschen viel Erfolg und Spaß beim Grabben Ihrer CDs. Werfen Sie auch einen Blick in die anderen FAQ-Sektionen, etwa, wie man qualitativ hochwertige MP3s erstellt. (Diese Sektion ist noch nicht erstellt)

Christof (ergänzt von start78)
« Letzte Änderung: 7. November 2007, 18:22:00 von start78 » Gespeichert
Seiten: [1] Drucken 
« vorheriges nächstes »
Gehe zu:  


Einloggen mit Benutzername, Passwort und Sitzungslänge

Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2011, Simple Machines Valid HTML 4.01! Valid CSS!
Seite erstellt in 0.024 Sekunden mit 27 Zugriffen.